هک سایتهای php

این تاپیک 1 پاسخ و 2 مشارکت کننده دارد . آخرین آپدیت توسط :  کیوان علی محمدی ،‏ 2 سال و 9 ماه پیش .

این تاپیک تاکنون 1658 بازدید داشته است .

نویسنده پست
جمعه ، 14 مارس 2014     8:33 ق.ظ #


ارشیا

Subscriber
22 پست40 تاپیک

در خیلی از مقالات هک دیدم که توصیه شده از

require

require_once

include

include_once

استفاده نشه چون باعث میشه سایت دارای باگ XSS بشه . پس اگر قرار باشه از اینا استفاده نشه تابع جایگزین چی هست ؟

تشکر

2  تشکر
جمعه ، 14 مارس 2014     11:39 ق.ظ #


کیوان علی محمدی

Authorplus
VIP
1792 پست4 تاپیک

سلام شما هر جایی برین از این دستورات استفاده شده،ولی به روش اصولی،خطر استفاده از این دستورات با وجود فعال بودن register_globals بیشتر میشه چون امکان تزریق صفحات دیگه به صفحه جاری بیشتره.هر چند این regsiter_globals به صورت پش فرض روی اکثر سرور ها غیر فعاله.

5  تشکر
پست 1 تا 2 (از مجموع 2 پست)

برای پاسخ دادن به این تاپیک باید وارد سایت شوید .