مشکل متن فارسی بعد از تغییر دامین سایت

این تاپیک 4 پاسخ و 2 مشارکت کننده دارد . آخرین آپدیت توسط :  donya2014 ،‏ 1 سال و 10 ماه پیش .

این تاپیک تاکنون 521 بازدید داشته است .

تگ شده :  

نویسنده پست
یکشنبه ، 18 ژانویه 2015     12:43 ب.ظ #


donya2014

Subscriber
5 پست9 تاپیک

سلام، خسته نباشید

چند ماهی هست که سایتی را آپلود کردم و متن های فارسی آن مشکلی نداشت، اما چند روزی که دامین سایت را تغییر دادم، بعد از تغییر دامین سایت در صفحه home سایت و صفحه index قسمت مدیریت (البته قسمت مدیریت را خودم طراحی کردم) متن های فارسی که در قسمت کدها نوشته شده به صورت علامت سوال (؟) شده، البته آن متنهایی که از پایگاه داده خونده میشه این مشکل را نداره، بقیه صفحات هم این مشکل را ندارن، صفحات را دوباره آپلود کردم اما مشکل حل نشد. لطفا کمک کنید، چی کار کنم...

0  تشکر
دوشنبه ، 19 ژانویه 2015     12:01 ق.ظ #


آرمین نادری

ناظم
389 پست39 تاپیک

اون متنهایی رو که میگی به شکل ؟؟؟ نشون داده میشن رو از دیتابیس گرفتی ؟

0  تشکر
دوشنبه ، 19 ژانویه 2015     12:44 ب.ظ #


donya2014

Subscriber
5 پست9 تاپیک

نه، اونایی که از دیتابیس میگیره مشکل نداره، متنی که بین تگها در کد نویسی نوشته شده این مشکل را داره، اون هم فقط دو تا صفحه از سایت، بقیه صفحات این مشکلو نداره... ممکنه مشکل از هاست باشه؟!...

0  تشکر
دوشنبه ، 19 ژانویه 2015     4:03 ب.ظ #


آرمین نادری

ناظم
389 پست39 تاپیک

میشه لطف کنی و آدرس اون صفحه رو بزاری یا برام ایمیل کنی ؟

armin.jb77@gmail.com

0  تشکر
شنبه ، 24 ژانویه 2015     8:23 ب.ظ #


donya2014

Subscriber
5 پست9 تاپیک

برای رفع مشکل اون صفحاتی که مشکل داشت را با برنامه notepad++ باز کردم و encoding شون را از نوع encode in utf-8 without BOM گذاشتم، ذخیره کردم و دوباره آپلود کردم، مشکل حل شد.

0  تشکر
پست 1 تا 5 (از مجموع 5 پست)

برای پاسخ دادن به این تاپیک باید وارد سایت شوید .