امکانش هست که ورد پرس نصب شده مشکل داشته باشه

این تاپیک 5 پاسخ و 3 مشارکت کننده دارد . آخرین آپدیت توسط :  mohammad karimi ،‏ 1 سال و 3 ماه پیش .

این تاپیک تاکنون 387 بازدید داشته است .

نویسنده پست
پنجشنبه ، 20 آگوست 2015     5:25 ب.ظ #


mohammad karimi

Subscriber
144 پست100 تاپیک

سلام خدمت دوستان گرمی؛من تازه کار هستم با ورد پرس من برای ایجاد ابزارک های خود از تابعی استفاده کردم  برای این کار که ابزارکی برای فرم باکس ورد کاربران خب بعد الان مشکلی تایپی داشتم یعنی خطای تایپی بعد الان درستش کردم هیچ اشکالی هم ندارد بازم این ابزارک برای من فعال نمیشه در پیشخوان»نمایش مشکلش کجاست،بعد الان فایل functionsرا که حذف کردم بعد در قسمت پیشخوان رفرش کردم پیغامی داد که ابزارک قالب شما غیرفعال گردید حالا به این شکل.ممنون میشم کمکم کنید.بازم فایل هامو در پیوست گذاشتم.

پیوست ها:
You must be logged in to view attached files.
1  تشکر
:: این تاپیک، پاسخ تائیدشده دارد : مشاهده پاسخ تائید شده توسط سوال کننده
جمعه ، 21 آگوست 2015     5:46 ق.ظ #


tarahi4site.com

Subscriber
39 پست4 تاپیک

دوست عزیز با توجه به اینکه شما تازه کار هستی من استفاده از افزونه Sidebar Login رو به شما توصیه میکنم!

این افزونه یک ابزارک برای شما میسازه و شما میتونید مثل بقیه ابزارکها اون رو به بغل سایتتون اضافه کنید

موفق باشید

0  تشکر
جمعه ، 21 آگوست 2015     4:16 ب.ظ #


lyon

Subscriber
31 پست21 تاپیک

با سلام

شما در این قسمت باز دچار اشتباه تایپی شده اید.

'description' => 'فرم لاگین',

شما باید این قسمت رو به این صورت بنویسید:

'description' => __( 'فرم لاگین'),

 

یعنی بعد از فلش دو تا زیرخط (underline) میخواد و بعد باید عبارت فرم لاگین رو داخل پرانتز بنویسید.

 

اولش سخته چون مبتدی هستش ولی انشاالله راه میفتید.

0  تشکر
جمعه ، 21 آگوست 2015     5:09 ب.ظ #


mohammad karimi

Subscriber
144 پست100 تاپیک

ممنون دوست عزیز از لطفت بازم فعال نشد.

0  تشکر
جمعه ، 21 آگوست 2015     9:57 ب.ظ # پاسخ تائید شده توسط سوال کننده


lyon

Subscriber
31 پست21 تاپیک

با سلام

به نظرم شما اشتباه تایپی دارید وگرنه مشکلی نباید داشته باشه

منکه الان دارم با functions.php  سایت خودم مقایسه میکنم

به این اشتباه ها رسیدم

دوتاشو که قبلا گفتم

الان چهار تا دیگه پیدا کردم

تو قسمت آخر یعنی اینجا
'after_widget' => '</div>',
نباید دیگه از کاما استفاده کنید

یعنی باید کامای انتهایی رو بردارید

شکل صحیح:
'after_widget' => '</div>'

 

همچین در این قسمت نیز نباید کامای انتهایی رو بذارید

'main-menu'=> __('منوی اصلی'),

شکل صحیح:

'main-menu'=> __('منوی اصلی')

 

همچنین شما آکولادهای if رو نذاشتید
اینجا رو میگم
if(function_exists('register_slidebar'))
register_slidebar (array(
'name' => 'widget',
'description' => 'فرم لاگین',
'before_title' => '<div class="login-top-box"><div class="title-login">',
'after_title' => '</div></div><div class="login-line"></div>',
'before_widget' => '<div id="Box-Form-Login">',
'after_widget' => '</div>',
));

شما باید آکولاد باز و بسته رو بذارید
شکل صحیح:
if(function_exists('register_slidebar')) {
register_slidebar (array(
'name' => 'widget',
'description' => 'فرم لاگین',
'before_title' => '<div class="login-top-box"><div class="title-login">',
'after_title' => '</div></div><div class="login-line"></div>',
'before_widget' => '<div id="Box-Form-Login">',
'after_widget' => '</div>',
));
}

 

همچین شما اسم سایدبار رو اشتباه نوشتید

اینجا رو میگم

register_slidebar

شما نوشتید اسلایدبار

شکل صحیح:

register_sidebar

 

در انتها functions.php سایت خودم رو لینک کردم که اگر باز مشکلی بود

خودتون باز مقایسه کنید که ببینید باز مشکلی هست یا ن.

 

http://s3.picofile.com/file/8207658034/1.php.html

اگه مشکل حل نشد باز در خدمتم

انشاالله امیدوارم که مشکل حل بشه!

1  تشکر
جمعه ، 21 آگوست 2015     10:16 ب.ظ #


mohammad karimi

Subscriber
144 پست100 تاپیک

ممنون حل شد اره چندتا اشتباه شدم.خیلی این فایل حساس است.خیلی خیلی ممنون از لطفت دوست عزیز.

0  تشکر
پست 1 تا 6 (از مجموع 6 پست)

این تاپیک پاسخ تائید شده دارد و بسته شده است .